Missing Listing Photos
Incident Report for Status Page
Resolved
This issue has been resolved, and the images have been restored. Our team is still monitoring health checks and will continue efforts to optimize performance.
Posted Jan 14, 2025 - 12:00 UTC
Investigating
Our Team is currently investigating an reported issue regarding listings no longer displaying available photos.
Posted Jan 13, 2025 - 23:48 UTC
This incident affected: US - Northeast Region, US - Southeast Region, US - Midwest Region, US - Southwest Region, US - West Region, and Canada.