A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2026 - 15:54 UTC
Investigating
We're currently investigating reports of intermittent Listing Detail page performance issues. Some users may experience slower-than-normal page loads, timeouts, or errors when accessing Listing Detail Pages. We've identified this as an issue with a third-party provider that supports our platform and are actively monitoring their incident while working to minimize the impact. No action is needed on your part at this time. We'll provide another update as soon as we have more information.
Posted Jul 28, 2026 - 14:34 UTC
This incident affected: US - Northeast Region, US - Southeast Region, US - Midwest Region, US - Southwest Region, US - West Region, and Canada.