Freezing Call List

Incident Report for Status Page

Resolved

The issue impacting the Call List has been resolved, and the service is fully operational.
Posted Apr 17, 2025 - 15:00 UTC

Investigating

We are currently aware of an issue where the Call List is freezing. Users are still able to place individual calls; however, initiating calls directly from the Call List may not function as expected during this issue. Our team is working expeditiously to restore service and appreciate your continued patience.
Posted Apr 16, 2025 - 19:11 UTC
This incident affected: US - Northeast Region, US - Southeast Region, US - Midwest Region, US - Southwest Region, US - West Region, and Canada.